デバッグモードだとYARPPが・・・なので修正

wordpressで人気のあるプラグインと言えば関連記事の出力。その中でもYARPPはメジャーですよねー。
でもWP4.3になってからデバッグモードで色々やってるとエラーメッセージがとても邪魔なので修正しました。

広告

デバッグモードでYARPPが出すエラーを修正する

エラーの原因はWP4.3で非推奨になったコードが含まれているのが原因です。
同様のエラーまみれ、僕も経験ありですww

エラー発生源は
classesフォルダのYARPP_Widget.php

このphpの上部に

parent::WP_Widget

があるので、コレを

parent::__construct

に変えて終了。

ではでは。

広告

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です